import re
regex = re.compile(r"#+.+\s+(?<paragraph>[^#]+)(?:\n\n|$)")
test_str = ("## Column A (Heading)\n"
"Paragraph A (Content)\n\n"
"## Column B (Heading)\n\n"
"Paragraph B (Content)\n"
"Paragraph B (Content)\n"
"Paragraph B (Content)\n"
"Paragraph B (Content)\n\n"
"## Column C (Heading)\n"
"Paragraph C (Content)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")