package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#+.+\s+(?<paragraph>[^#]+)(?:\n\n|$)`)
var str = `## Column A (Heading)
Paragraph A (Content)
## Column B (Heading)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
## Column C (Heading)
Paragraph C (Content)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}