re = /#+.+\s+(?<paragraph>[^#]+)(?:\n\n|$)/
str = '## Column A (Heading)
Paragraph A (Content)
## Column B (Heading)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
## Column C (Heading)
Paragraph C (Content)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end