$re = '/#+.+\s+(?<paragraph>[^#]+)(?:\n\n|$)/';
$str = '## Column A (Heading)
Paragraph A (Content)
## Column B (Heading)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
## Column C (Heading)
Paragraph C (Content)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);