import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#+.+\\s+(?<paragraph>[^#]+)(?:\\n\\n|$)";
final String string = "## Column A (Heading)\n"
+ "Paragraph A (Content)\n\n"
+ "## Column B (Heading)\n\n"
+ "Paragraph B (Content)\n"
+ "Paragraph B (Content)\n"
+ "Paragraph B (Content)\n"
+ "Paragraph B (Content)\n\n"
+ "## Column C (Heading)\n"
+ "Paragraph C (Content)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}