using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#+.+\s+(?<paragraph>[^#]+)(?:\n\n|$)";
string input = @"## Column A (Heading)
Paragraph A (Content)
## Column B (Heading)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
Paragraph B (Content)
## Column C (Heading)
Paragraph C (Content)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}