# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9][0-9| ]*\/?[0-9| -]*[0-9])/<a href="tel:\1">\1<\/a>/gm;t' <<< "Tel: 02342/379 287 Mob: 06790/3234-232 Gesch: 22375 Tel2: 033 82/27-8-84 / 27437"