use strict;
my $str = 'Tel: 02342/379 287 Mob: 06790/3234-232 Gesch: 22375 Tel2: 033 82/27-8-84 / 27437';
my $regex = qr/([0-9][0-9| ]*/?[0-9| -]*[0-9])/mp;
my $subst = '<a href="tel:\\1">\\1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";