// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9][0-9| ]*/?[0-9| -]*[0-9])").unwrap();
let string = "Tel: 02342/379 287 Mob: 06790/3234-232 Gesch: 22375 Tel2: 033 82/27-8-84 / 27437";
let substitution = "<a href=\"tel:\\1\">\\1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}