# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\s*(?<!#)\s*PRIMER_PRODUCT_SIZE_RANGE\s*)=.*$/\1=500-300/gm;t' <<< "# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy
PRIMER_PRODUCT_SIZE_RANGE=100-300
PRIMER_NUM_RETURN=3
PRIMER_MAX_END_STABILITY=9.0
PRIMER_MAX_HAIRPIN_TH=24.0"