import Foundation
let pattern = ##"^(\s*(?<!#)\s*PRIMER_PRODUCT_SIZE_RANGE\s*)=.*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy
PRIMER_PRODUCT_SIZE_RANGE=100-300
PRIMER_NUM_RETURN=3
PRIMER_MAX_END_STABILITY=9.0
PRIMER_MAX_HAIRPIN_TH=24.0
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1=500-300"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)