re = /^(\s*(?<!#)\s*PRIMER_PRODUCT_SIZE_RANGE\s*)=.*$/m
str = '# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy
PRIMER_PRODUCT_SIZE_RANGE=100-300
PRIMER_NUM_RETURN=3
PRIMER_MAX_END_STABILITY=9.0
PRIMER_MAX_HAIRPIN_TH=24.0'
subst = '\\1=500-300'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result