#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*(?<!#)\s*PRIMER_PRODUCT_SIZE_RANGE\s*)=.*$"
Local $sString = "# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy" & @CRLF & _
"PRIMER_PRODUCT_SIZE_RANGE=100-300" & @CRLF & _
"PRIMER_NUM_RETURN=3" & @CRLF & _
"PRIMER_MAX_END_STABILITY=9.0" & @CRLF & _
"" & @CRLF & _
"PRIMER_MAX_HAIRPIN_TH=24.0"
Local $sSubst = "\1=500-300"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)