import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*(?<!#)\\s*PRIMER_PRODUCT_SIZE_RANGE\\s*)=.*$";
final String string = "# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy\n"
+ "PRIMER_PRODUCT_SIZE_RANGE=100-300\n"
+ "PRIMER_NUM_RETURN=3\n"
+ "PRIMER_MAX_END_STABILITY=9.0\n\n"
+ "PRIMER_MAX_HAIRPIN_TH=24.0";
final String subst = "\\1=500-300";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}