use strict;
my $str = '# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy
PRIMER_PRODUCT_SIZE_RANGE=100-300
PRIMER_NUM_RETURN=3
PRIMER_MAX_END_STABILITY=9.0
PRIMER_MAX_HAIRPIN_TH=24.0';
my $regex = qr/^(\s*(?<!#)\s*PRIMER_PRODUCT_SIZE_RANGE\s*)=.*$/mp;
my $subst = '\\1=500-300';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";