const regex = new RegExp('^(\\s*(?<!#)\\s*PRIMER_PRODUCT_SIZE_RANGE\\s*)=.*$', 'gm')
const str = `# PRIMER_PRODUCT_SIZE_RANGE=xxx-yyy
PRIMER_PRODUCT_SIZE_RANGE=100-300
PRIMER_NUM_RETURN=3
PRIMER_MAX_END_STABILITY=9.0
PRIMER_MAX_HAIRPIN_TH=24.0`;
const subst = `\1=500-300`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);