using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[|\G(?!^))\K[^][](?=[^][]*])";
string substitution = @"$0█";
string input = @"$lang['activate_deactivate'] = ""Activate / Deactivate"";
$lang['invalid_username'] = ""Invalid username"";
$lang['you_must_enter_username'] = ""You must enter username"";
$lang['invalid_user_name'] = ""Invalid username"";
$lang['user_deactivated'] = ""User has been deactivated"";
$lang['user_not_deactivated'] = ""User could not be deactivated"";";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}