import Foundation
let pattern = #"(?:\[|\G(?!^))\K[^][](?=[^][]*])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$lang['activate_deactivate'] = "Activate / Deactivate";
$lang['invalid_username'] = "Invalid username";
$lang['you_must_enter_username'] = "You must enter username";
$lang['invalid_user_name'] = "Invalid username";
$lang['user_deactivated'] = "User has been deactivated";
$lang['user_not_deactivated'] = "User could not be deactivated";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0█"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)