# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\[|\G(?!^))\K[^][](?=[^][]*])"
test_str = ("$lang['activate_deactivate'] = \"Activate / Deactivate\";\n"
"$lang['invalid_username'] = \"Invalid username\";\n"
"$lang['you_must_enter_username'] = \"You must enter username\";\n"
"$lang['invalid_user_name'] = \"Invalid username\";\n"
"$lang['user_deactivated'] = \"User has been deactivated\";\n"
"$lang['user_not_deactivated'] = \"User could not be deactivated\";")
subst = "$0█"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.