import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[|\\G(?!^))\\K[^][](?=[^][]*])";
final String string = "$lang['activate_deactivate'] = \"Activate / Deactivate\";\n"
+ "$lang['invalid_username'] = \"Invalid username\";\n"
+ "$lang['you_must_enter_username'] = \"You must enter username\";\n"
+ "$lang['invalid_user_name'] = \"Invalid username\";\n"
+ "$lang['user_deactivated'] = \"User has been deactivated\";\n"
+ "$lang['user_not_deactivated'] = \"User could not be deactivated\";";
final String subst = "$0█";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}