use strict;
my $str = '$lang[\'activate_deactivate\'] = "Activate / Deactivate";
$lang[\'invalid_username\'] = "Invalid username";
$lang[\'you_must_enter_username\'] = "You must enter username";
$lang[\'invalid_user_name\'] = "Invalid username";
$lang[\'user_deactivated\'] = "User has been deactivated";
$lang[\'user_not_deactivated\'] = "User could not be deactivated";';
my $regex = qr/(?:\[|\G(?!^))\K[^][](?=[^][]*])/mp;
my $subst = '$0█';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";