const regex = /(?:\[|\G(?!^))\K[^][](?=[^][]*])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[|\\G(?!^))\\K[^][](?=[^][]*])', 'gm')
const str = `\$lang['activate_deactivate'] = "Activate / Deactivate";
\$lang['invalid_username'] = "Invalid username";
\$lang['you_must_enter_username'] = "You must enter username";
\$lang['invalid_user_name'] = "Invalid username";
\$lang['user_deactivated'] = "User has been deactivated";
\$lang['user_not_deactivated'] = "User could not be deactivated";`;
const subst = `$0█`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);