# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[a-z\s]+id=[\'\"]mobile[\w]+[\'\"][\sa-zA-Z\d\'\=\;\:]*>([a-zA-Z\d\s]+)<[\\/a-z\s]+>/$1/g;t' <<< "<div id='mobileBody'>Message</div>
<div id=\"mobiletitle\" >Message</div>
<div id='mobileBody' style='display:none;'>Message</div>
<div id='mobileTitle' style='display:none;'>Message</div>
<div id=\"title\" >asd</div>
<div id=\"title\">asd</div>"