import Foundation
let pattern = #"<[a-z\s]+id=[\'\"]mobile[\w]+[\'\"][\sa-zA-Z\d\'\=\;\:]*>([a-zA-Z\d\s]+)<[\/a-z\s]+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div id='mobileBody'>Message</div>
<div id="mobiletitle" >Message</div>
<div id='mobileBody' style='display:none;'>Message</div>
<div id='mobileTitle' style='display:none;'>Message</div>
<div id="title" >asd</div>
<div id="title">asd</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)