package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[a-z\s]+id=[\'\"]mobile[\w]+[\'\"][\sa-zA-Z\d\'\=\;\:]*>([a-zA-Z\d\s]+)<[\/a-z\s]+>`)
var str = `<div id='mobileBody'>Message</div>
<div id="mobiletitle" >Message</div>
<div id='mobileBody' style='display:none;'>Message</div>
<div id='mobileTitle' style='display:none;'>Message</div>
<div id="title" >asd</div>
<div id="title">asd</div>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}