using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[a-z\s]+id=[\'\""]mobile[\w]+[\'\""][\sa-zA-Z\d\'\=\;\:]*>([a-zA-Z\d\s]+)<[\/a-z\s]+>";
string substitution = @"$1";
string input = @"<div id='mobileBody'>Message</div>
<div id=""mobiletitle"" >Message</div>
<div id='mobileBody' style='display:none;'>Message</div>
<div id='mobileTitle' style='display:none;'>Message</div>
<div id=""title"" >asd</div>
<div id=""title"">asd</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}