$re = '/<[a-z\s]+id=[\'\"]mobile[\w]+[\'\"][\sa-zA-Z\d\'\=\;\:]*>([a-zA-Z\d\s]+)<[\/a-z\s]+>/';
$str = '<div id=\'mobileBody\'>Message</div>
<div id="mobiletitle" >Message</div>
<div id=\'mobileBody\' style=\'display:none;\'>Message</div>
<div id=\'mobileTitle\' style=\'display:none;\'>Message</div>
<div id="title" >asd</div>
<div id="title">asd</div>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;