const regex = /<[a-z\s]+id=[\'\"]mobile[\w]+[\'\"][\sa-zA-Z\d\'\=\;\:]*>([a-zA-Z\d\s]+)<[\/a-z\s]+>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[a-z\\s]+id=[\\\'\\"]mobile[\\w]+[\\\'\\"][\\sa-zA-Z\\d\\\'\\=\\;\\:]*>([a-zA-Z\\d\\s]+)<[\\\/a-z\\s]+>', 'g')
const str = `<div id='mobileBody'>Message</div>
<div id="mobiletitle" >Message</div>
<div id='mobileBody' style='display:none;'>Message</div>
<div id='mobileTitle' style='display:none;'>Message</div>
<div id="title" >asd</div>
<div id="title">asd</div>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);