using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)(if[ \t]+\([^=\n\/\;]+)(?<![\<\!\>])=([^=\n\/\;]+\))";
string substitution = @"$1==$2";
string input = @"
} else if (iy>=PixmapHeight(Pixmap)-1-5 && ix>=5 && ix<=PixmapWidth(Pixmap)-1-5){
if (PointToX!=-1){
//выводим возможные ошибки
if (ads = null){
tLog.Error(""AudioDrivers list is null"");
return;
} //EndIf
if (BM.Len(ads) = 0){
//если драйвер не установлен - выбираем первый
if (AudioDriver = null){";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}