import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)(if[ \\t]+\\([^=\\n\\/\\;]+)(?<![\\<\\!\\>])=([^=\\n\\/\\;]+\\))";
final String string = "\n"
+ "} else if (iy>=PixmapHeight(Pixmap)-1-5 && ix>=5 && ix<=PixmapWidth(Pixmap)-1-5){\n\n"
+ "if (PointToX!=-1){\n"
+ " //выводим возможные ошибки\n"
+ " if (ads = null){\n"
+ " tLog.Error(\"AudioDrivers list is null\");\n"
+ " return;\n"
+ " } //EndIf\n"
+ " if (BM.Len(ads) = 0){ \n"
+ "//если драйвер не установлен - выбираем первый\n"
+ " if (AudioDriver = null){";
final String subst = "$1==$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}