import re
regex = re.compile(r"(?<=\s)(if[ \t]+\([^=\n\/\;]+)(?<![\<\!\>])=([^=\n\/\;]+\))", flags=re.MULTILINE)
test_str = ("\n"
"} else if (iy>=PixmapHeight(Pixmap)-1-5 && ix>=5 && ix<=PixmapWidth(Pixmap)-1-5){\n\n"
"if (PointToX!=-1){\n"
" //выводим возможные ошибки\n"
" if (ads = null){\n"
" tLog.Error(\"AudioDrivers list is null\");\n"
" return;\n"
" } //EndIf\n"
" if (BM.Len(ads) = 0){ \n"
"//если драйвер не установлен - выбираем первый\n"
" if (AudioDriver = null){")
subst = "$1==$2"
result = regex.sub(subst, test_str)
if result:
print(result)