const regex = /(?<=\s)(if[ \t]+\([^=\n\/\;]+)(?<![\<\!\>])=([^=\n\/\;]+\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)(if[ \\t]+\\([^=\\n\\\/\\;]+)(?<![\\<\\!\\>])=([^=\\n\\\/\\;]+\\))', 'gm')
const str = `
} else if (iy>=PixmapHeight(Pixmap)-1-5 && ix>=5 && ix<=PixmapWidth(Pixmap)-1-5){
if (PointToX!=-1){
//выводим возможные ошибки
if (ads = null){
tLog.Error("AudioDrivers list is null");
return;
} //EndIf
if (BM.Len(ads) = 0){
//если драйвер не установлен - выбираем первый
if (AudioDriver = null){`;
const subst = `$1==$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);