import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\begin\\{(align|equation)\\*?\\}(?P<eq>(.)+?)\\\\end\\{(align|equation)\\*?\\}";
final String string = "This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.\n"
+ "\\begin{align}\\label{eq:some_label}\n"
+ " E = m * c^2\n"
+ "\\end{align}\n\n"
+ "Below is an equation\n"
+ "\\begin{equation}\n"
+ " P_k(t) = K (T_2(t) - T_o(t))\n"
+ "\\end{equation}\n\n"
+ "Below is both and align and equation with starred variants:\n"
+ "\\begin{align*}\n"
+ " E = m * c^2\n"
+ "\\end{align*}\n"
+ "\\begin{equation*}\n"
+ " E = m * c^2\n"
+ "\\end{align*}\n\n"
+ "And on one line:\n"
+ "\\begin{equation*}E = m * c^2\\end{align*}\n\n"
+ "And another environment\n"
+ "\\begin{figure}\n"
+ " ...\n"
+ "\\end{figure}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}