// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\\begin{(align|equation)\*?}(?P<eq>(.)+?)\\end{(align|equation)\*?}").unwrap();
let string = "This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.
\\begin{align}\\label{eq:some_label}
E = m * c^2
\\end{align}
Below is an equation
\\begin{equation}
P_k(t) = K (T_2(t) - T_o(t))
\\end{equation}
Below is both and align and equation with starred variants:
\\begin{align*}
E = m * c^2
\\end{align*}
\\begin{equation*}
E = m * c^2
\\end{align*}
And on one line:
\\begin{equation*}E = m * c^2\\end{align*}
And another environment
\\begin{figure}
...
\\end{figure}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}