const regex = new RegExp('\\\\begin{(align|equation)\\*?}(?P<eq>(.)+?)\\\\end{(align|equation)\\*?}', 'gms')
const str = `This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.
\\begin{align}\\label{eq:some_label}
E = m * c^2
\\end{align}
Below is an equation
\\begin{equation}
P_k(t) = K (T_2(t) - T_o(t))
\\end{equation}
Below is both and align and equation with starred variants:
\\begin{align*}
E = m * c^2
\\end{align*}
\\begin{equation*}
E = m * c^2
\\end{align*}
And on one line:
\\begin{equation*}E = m * c^2\\end{align*}
And another environment
\\begin{figure}
...
\\end{figure}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}