import Foundation
let pattern = #"\\begin{(align|equation)\*?}(?P<eq>(.)+?)\\end{(align|equation)\*?}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.
\begin{align}\label{eq:some_label}
E = m * c^2
\end{align}
Below is an equation
\begin{equation}
P_k(t) = K (T_2(t) - T_o(t))
\end{equation}
Below is both and align and equation with starred variants:
\begin{align*}
E = m * c^2
\end{align*}
\begin{equation*}
E = m * c^2
\end{align*}
And on one line:
\begin{equation*}E = m * c^2\end{align*}
And another environment
\begin{figure}
...
\end{figure}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)