$re = '/\\\\begin{(align|equation)\*?}(?P<eq>(.)+?)\\\\end{(align|equation)\*?}/ms';
$str = 'This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.
\\begin{align}\\label{eq:some_label}
E = m * c^2
\\end{align}
Below is an equation
\\begin{equation}
P_k(t) = K (T_2(t) - T_o(t))
\\end{equation}
Below is both and align and equation with starred variants:
\\begin{align*}
E = m * c^2
\\end{align*}
\\begin{equation*}
E = m * c^2
\\end{align*}
And on one line:
\\begin{equation*}E = m * c^2\\end{align*}
And another environment
\\begin{figure}
...
\\end{figure}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);