import re
regex = re.compile(r"\\begin{(align|equation)\*?}(?P<eq>(.)+?)\\end{(align|equation)\*?}", flags=re.MULTILINE | re.DOTALL)
test_str = ("This is a test of the regular expression. Below is an equation with a label on the same line as begin and an equation on a new line.\n"
"\\begin{align}\\label{eq:some_label}\n"
" E = m * c^2\n"
"\\end{align}\n\n"
"Below is an equation\n"
"\\begin{equation}\n"
" P_k(t) = K (T_2(t) - T_o(t))\n"
"\\end{equation}\n\n"
"Below is both and align and equation with starred variants:\n"
"\\begin{align*}\n"
" E = m * c^2\n"
"\\end{align*}\n"
"\\begin{equation*}\n"
" E = m * c^2\n"
"\\end{align*}\n\n"
"And on one line:\n"
"\\begin{equation*}E = m * c^2\\end{align*}\n\n"
"And another environment\n"
"\\begin{figure}\n"
" ...\n"
"\\end{figure}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")