#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b"
Local $sString = "11/11/1111" & @CRLF & _
"11-11-1111" & @CRLF & _
"11 11 1111" & @CRLF & _
"11- 11- 1111" & @CRLF & _
"11 11 1111" & @CRLF & _
"11-11 1111" & @CRLF & _
"23- 10-17" & @CRLF & _
"9 06- 17" & @CRLF & _
"1$0%11" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")