re = /\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b/
str = '11/11/1111
11-11-1111
11 11 1111
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
1$0%11
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end