use strict;
my $str = '11/11/1111
11-11-1111
11 11 1111
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
1$0%11
';
my $regex = qr/\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}