const regex = /\b(?:\d{1,2}[- \/]\s?){2}(?:\d{4}|\d{2})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:\\d{1,2}[- \\\/]\\s?){2}(?:\\d{4}|\\d{2})\\b', 'g')
const str = `11/11/1111
11-11-1111
11 11 1111
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
1\$0%11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}