#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?<![\p{Letter}\d_])test(?![\p{Letter}\d_])"
Local $sString = "teststring" & @CRLF & _
"testö" & @CRLF & _
"testœ" & @CRLF & _
"test1" & @CRLF & _
"test_" & @CRLF & _
"" & @CRLF & _
"test." & @CRLF & _
"test," & @CRLF & _
"test/" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"stringtest" & @CRLF & _
"ötest" & @CRLF & _
"œtest" & @CRLF & _
"1test" & @CRLF & _
"_test" & @CRLF & _
"" & @CRLF & _
".test" & @CRLF & _
",test" & @CRLF & _
"/test" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")