using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\p{Letter}\d_])test(?![\p{Letter}\d_])";
string input = @"teststring
testö
testœ
test1
test_
test.
test,
test/
test
stringtest
ötest
œtest
1test
_test
.test
,test
/test
test
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}