import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\p{Letter}\\d_])test(?![\\p{Letter}\\d_])";
final String string = "teststring\n"
+ "testö\n"
+ "testœ\n"
+ "test1\n"
+ "test_\n\n"
+ "test.\n"
+ "test,\n"
+ "test/\n"
+ "test\n\n"
+ "stringtest\n"
+ "ötest\n"
+ "œtest\n"
+ "1test\n"
+ "_test\n\n"
+ ".test\n"
+ ",test\n"
+ "/test\n"
+ "test\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}