$re = '/(?<![\p{Letter}\d_])test(?![\p{Letter}\d_])/u';
$str = 'teststring
testö
testœ
test1
test_
test.
test,
test/
test
stringtest
ötest
œtest
1test
_test
.test
,test
/test
test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);