re = /(?<![\p{Letter}\d_])test(?![\p{Letter}\d_])/
str = 'teststring
testö
testœ
test1
test_
test.
test,
test/
test
stringtest
ötest
œtest
1test
_test
.test
,test
/test
test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end