# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<h1>(.+?)<\\/h1>)<img class=".*?" alt="[^"]+" (src="[^"]+")>/\1<img \3 alt="\2">/gm;t' <<< "<h1>Bla-bla-bla</h1><img class=\"class\" alt=\"image\" src=\"img.jpg\">
"