use strict;
my $str = '<h1>Bla-bla-bla</h1><img class="class" alt="image" src="img.jpg">
';
my $regex = qr/(<h1>(.+?)<\/h1>)<img class=".*?" alt="[^"]+" (src="[^"]+")>/mp;
my $subst = '\\1<img \\3 alt="\\2">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";