$re = '/(<h1>(.+?)<\/h1>)<img class=".*?" alt="[^"]+" (src="[^"]+")>/m';
$str = '<h1>Bla-bla-bla</h1><img class="class" alt="image" src="img.jpg">
';
$subst = "\1<img \3 alt=\"\2\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;